The Demo doesn't work

I have downloaded the demo but when I click it it says loading and when it’s done loading it just dissapears.
I have Game Maker installed but I do not now exactly how that works. If I have to open it through Game Maker or something like that, I’m sorry. I really don’t know how Game Maker works. (and no, I don’t use a Mac, I have Windows XP installed)

You have to be more specific than that.

  • Does it play the warning sound after it disappears?
  • When opening task manager, does it say the program/process is running?
  • In the same instance, what is the cpu usage? Did it spike?

Okay I checked, the CPU level spikes and the program is shown in the task list but as soon as the the loading screen dissapears the proces dissapears and the CPU level returns to normal and I don’t hear any sound, it just dissapears.

My demo shuts itself off because of errors (I got rid of my gamemaker 6, so I can’t see the problem)

Where are downloading the demo from? That might be part of the problem.

I got it from the main website.

It works on my new computer but not my old one.

What OS is your computer? (Xp?)

EDIT: If your demo works, could ya PM me or send me an email with your demo attached? Thanks!

I hate to bump an old topic, but I guess this is the correct place to put this?

When I downloaded both the first and last demos of p2d from the site, I got the same error messages: (after I unzipped them and tried to execute them)

“Invalid pointer operation.”
and the standard program needs to close box,
“p2d_df_2-6.exe has encountered a problem and needs to close. […]”

Any hints?

Oh, and by the way, I didn’t try any of the files between those two…

Ya get a better computer, not much else I can think of.

Try this:

  • update windows
  • update directx
  • update your video card drivers

Ok, I’ll see about those…

I’ve got XP home edition; what operating systems has it been working on for you guys?

Demo is working fine under Windows Me.

I have XP home edition, too. It seems that you can’t run any games made in Game Maker 6 (try some out and see if you get the same error–look for topics with a GM6 icon). Following what DF recommended should help.